28 Dec 2009 @ 1:12 PM 

If I can be bothered to re-install Crysis, I might have a look at this mod.  MechWarrior: Living Legends Website has the beta 1.0 of this Crysis mod which uses MechWarriors, you need the retail version of Crysis updated to 1.21 to play.

Posted By: Seahorse
Last Edit: 28 Dec 2009 @ 01:12 PM

EmailPermalink
Tags
Tags: ,
Categories: Gaming


 

Responses to this post » (None)

 
Post a Comment

XHTML: You can use these tags: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

 


 Last 50 Posts
Change Theme...
  • Users » 4
  • Posts/Pages » 762
  • Comments » 45
Change Theme...
  • VoidVoid « Default
  • LifeLife
  • EarthEarth
  • WindWind
  • WaterWater
  • FireFire
  • LightLight

About



    No Child Pages.